Required Plugins

The required plugins to get OPTIM up and running.

There are multiple different Unreal Engine base plugins that are required to get the different aspects of OPTIM to work as intended. If one or many of the plugins listed below are not enabled, you will experience irregularities or even errors.

All of the required plugins are enabled by default once OPTIM is enabled. This page is to clarify that these plugins are required and should not be un-enabled in order to provide an ideal Unreal Engine and OPTIM experience.

Accessing The Plugins Window

If you are not familiar with Unreal Engine or the Plugins window, you can access it via ---

  • Menu Bar -> Edit -> Plugins

  • Tool Bar -> Settings -> Plugins

Core

These plugins are absolutely required in order for OPTIM to work as intended.

Plugin

Location

Optim

Theia

Python Editor Script Plugin

Scripting

Editor Scripting Utilities

Scripting

Importer

The Importer requires a few additional plugins to support the import process.

Plugin

Location

Datasmith Importer

Importers

Datasmith CAD Importer

Importers

Datasmith glTF Importer

Importers

Datsmith Content

Importers

Template

The Template requires additional plugins for online, VR, and FX support.

These plugins are automatically enabled when the Collaborative Template is installed.

Plugin

Location

Optim Template Plugin

Theia

Advanced Sessions

Advanced Sessions Plugin

Online Subsystem Null

Online Platform

Online Subsystem Steam

Online Platform

Online Subsystem Utils

Online Platform

Oculus VR

Virtual Reality

SteamVR

Virtual Reality

Microsoft Windows Mixed Reality

Virtual Reality